LCDproc development and user support list

Text archives Help


[Lcdproc] Small patch to improve readablity of HD44780_backlight


Chronological Thread 
  • From: bsdfan at nurfuerspam.de (Markus Dolze)
  • Subject: [Lcdproc] Small patch to improve readablity of HD44780_backlight
  • Date: Mon, 30 Jan 2012 20:05:18 +0100

On 29.01.2012 12:49, Thomas Mohaupt wrote:
> Hi,
>
> while write a hd44780 subdriver I stumble over
>
> MODULE_EXPORT void HD44780_backlight(Driver *drvthis, int on)
>
> IMHO the parameter name "on" may lead to missinterpretation.
>
> Attached is a small patch to rename it to "state" - (as already done
> in some subdrivers.)
>
> Regards,
> ThoMo
>

Hi,

thank you for your submission.

Anyway, I will not commit it.

While 'state' seems to be commonly used by hd44780 sub-drivers and I
even adapted this habbit for the glcd driver, 'on' is used by all
(except one) top level drivers and that is the name in lcd.h as well.

Regards,
Markus





Archive powered by MHonArc 2.6.18.

Top of page