LCDproc development and user support list

Text archives Help


[Lcdproc] CrytalFontz 635 LCDd.conf issues


Chronological Thread 
  • From: bsdfan at nurfuerspam.de (Markus Dolze)
  • Subject: [Lcdproc] CrytalFontz 635 LCDd.conf issues
  • Date: Sun, 27 Feb 2011 13:14:24 +0100

-------- Original-Nachricht --------
> Datum: Fri, 25 Feb 2011 19:56:36 +0100
> Von: Markus Dolze <bsdfan at nurfuerspam.de>
> An: jsalk at salk.net
> CC: lcdproc at lists.omnipotent.net
> Betreff: Re: [Lcdproc] CrytalFontz 635 LCDd.conf issues

> On 24.02.2011 22:07, Jim Salk wrote:
> > Below is my LCDd.conf file. For some reason, the "Hello" lines never
> > get displayed. The "Goodbye" lines do, although they do not replace
> > any characters to the right of any space. So the original letters in
> > the CrystalFontz boot screen remain. Contast and brightness work.
> > Nothing works if I do not have "Reboot" set to yes.
> >
> > When I run LCDd, the CrystalFontz boot screen shows, the brightness
> > and contrast get readjusted and a portion of the first three lines
> > changes. The first line shows "LCDproc Server" with a beating heart
> > in the rightmost position. The second line reads "Clients: 0" plus
> > the remaining characters from the boot screen. The third line reads
> > "Screens: 0" plus the remaining characters from the boot screen. The
> > fourth line is unchanged from the boot screen.
> >
> > The "Hello" text is never displayed.
> >
> > Any advice would be appreciated. Here is my LCDd.conf file:
> >
>
> Hi,
>
> unfortunately I cannot reproduce your problem using my CFA 635
> (XES635BKTMFKU) and your config (I had to use different values for
> brightness and contrast as well).
>
> In fact I do see the Hello screen until a client connects. It also works
> with and without reboot=yes.
>
> You may actually face two problems: First the display is not cleared
> during initialization. Second you do not see the Hello message.
>
> The display is cleared on startup using a hardware command. I am not
> aware of any firmware version that does not support this command. But
> you may try the attached patch. It initializes one buffer differently so
> whole screen is redrawn upon startup.
>
> As you do see the server screen you should see the Hello message as that
> uses standard drawing functions. I will have a close look at this, but
> as I wrote above, it does work here...
>
> Regards,
> Markus
>

I tried to find out what may be your problem with the hello message, but I
cannot find anything wrong at a first glance.

To help with debugging this I ask you to try the attached patch and run 'LCDd
-r 4 -f' (report level info, run in foreground) and send me the output of
that.

It should contain something like this:

server_screen_init(), hello=4
line1 = [ ]
line2 = [ Welcome ]
line3 = [ ]
line4 = [ ]

Regards,
Markus
-------------- next part --------------
A non-text attachment was scrubbed...
Name: serverscreen-debug-hello.patch
Type: application/octet-stream
Size: 935 bytes
Desc: not available
URL:
<http://lists.omnipotent.net/pipermail/lcdproc/attachments/20110227/a58af4fb/attachment.obj>




Archive powered by MHonArc 2.6.18.

Top of page