LCDproc development and user support list

Text archives Help


[Lcdproc] Fwd: lcdproc on FreeBSD with lis driver


Chronological Thread 
  • From: wyatt at prairieturtle.ca (Daryl F)
  • Subject: [Lcdproc] Fwd: lcdproc on FreeBSD with lis driver
  • Date: Tue, 7 Dec 2010 20:52:44 -0600 (CST)

Sorry, I can't help you. I wasn't working when I worked on the lis driver
but I've got my hands full now and it takes a long time to snoop out the
initialization sequence.

>From the picture you sent they are a least using slightly different
firmware. The firmware between the FTDI chip and the serial interface on
the HD44780-compatible chip on my model is what displays the banner at
power on.

I looked at the newegg pictures of the back of the unit and it is similiar
arrangement to the one I have. Daughter board with the FTDI chip and
firmware chip attached on top of the board with the display and
HD44780-compatible VFD driver chip. I bet it is even the same NEC driver
chip but not necessarily.

You might contact postmaster at vlsys.co.kr and see if they plan to release a
driver for it or if they might give you the init. sequence. It might be
easy for you to adapt the lis driver.

-Daryl

On Mon, 6 Dec 2010, Tom Pusateri wrote:

> Thanks for the info.
>
> Here's my unit:
>
> http://www.newegg.com/Product/Product.aspx?Item=N82E16811996003&cm_re=nMedia_pro_lcd-_-11-996-003-_-Product
>
> I can send you one to keep if you're willing to try and make it work.
>
> Thanks,
> Tom
>
> On Dec 6, 2010, at 5:34 PM, Daryl F wrote:
>
>> Tom,
>>
>> The lis driver must have thread support to work. It will only work with a
>> very specific VLSys VFD. At power on the display must say it is a L.I.S.
>> MCE 2005 or it is likely this driver will not work and will indeed hang
>> LCDd.
>>
>> Markus was right. The thread will never return until shutdown. It is
>> specifically a loop to keep a read up on the FTDI chip at all times. The
>> main thread uses a semaphore to break the loop and end the thread at
>> shutdown.
>>
>> VLSys includes firmware between the FTDI chip and the HD44780 chip on the
>> LIS MCE 2005. The initialization code in the lis driver works only with
>> that firmware.
>>
>> <history>
>> Conversely, I never could get the lis2 HD44780 variant to work with the
>> MCE 2005. It lacked that specific initialization sequence which I
>> discovered by snooping the USB stream on a Windows machine using VLSys
>> supplied driver. VLSys gave approval for this reverse-engineering to be
>> included in the lis driver and distributed with ldcproc
>> </history>
>>
>> So it may not be a bug in BSD pthread but rather the wrong display for the
>> lis driver. I couldn't find any information at the link you have for the
>> nMedia 1000 case that clearly said which VLSys lis the display actually
>> was.
>>
>> I don't have acess to the MCE 2005 for testing on my BSD machine. It is in
>> production under Linux and I don't have another to test with.
>>
>> HTH,
>> Daryl
>>
>>
>> On Sun, 5 Dec 2010, Tom Pusateri wrote:
>>
>>> Thanks for the reply.
>>>
>>> The code looks fine to me too. But the call to pthread_create never
>>> returns so maybe its an issue with FreeBSD 8.1. I just did a binary
>>> update to p2 and that acts the same. I saw a Freebsd bug in 7.2 for a
>>> similar problem to pthread_create() not returning because of a malloc
>>> issue.
>>>
>>> I read elsewhere that others on linux are using the hd44780 Driver with
>>> connection type lis2. So I tried that with device /dev/cuaU0. It seems to
>>> run ok but it never updates the display. Its not clear which driver I
>>> should be using.
>>>
>>> I don't think I mentioned it before but I have a Pro-LCD in a nMedia 1000
>>> case http://www.nmediapc.com/LCD/download.htm which is a VLSys LIS MCE.
>>>
>>> Thanks for the help.
>>>
>>> Tom
>>> On Dec 5, 2010, at 2:42 AM, Markus Dolze wrote:
>>>
>>>> Hello,
>>>>
>>>> yes, the LIS driver is the only driver that uses threads. At first
>>>> glance I can't see any problem with the code.
>>>>
>>>> Are you sure you are not looking at the second thread launched in gdb?
>>>> That thread will only return on shutdown.
>>>>
>>>> Which version of LCDproc and FreeBSD (output of uname -v) are you using?
>>>>
>>>> Regards,
>>>> Markus
>>>>
>>>> On 04.12.2010 23:09, Tom Pusateri wrote:
>>>>> Some more info: In gdb, it is never returning from pthread_create() in
>>>>> lis.c:514
>>>>>
>>>>> The lis driver appears to be the only driver that uses threads.
>>>>>
>>>>> Thanks,
>>>>> Tom
>>>>>
>>>>> Begin forwarded message:
>>>>>
>>>>>> *From: *Tom Pusateri
>>>>>> *Date: *December 4, 2010 3:43:02 PM EST
>>>>>> *To: *bsdfan at nurfuerspam.de <mailto:bsdfan at nurfuerspam.de>
>>>>>> *Subject: **lcdproc on FreeBSD with lis driver*
>>>>>>
>>>>>> I have built the lcdproc code using a modified port to include the lis
>>>>>> driver (which depends on devel/libftdi).
>>>>>>
>>>>>> libftdi seems to work and the utilities that ship with it seem to work
>>>>>> but LCDd hangs on startup. I'm running gdb now to see if I can figure
>>>>>> out why but I wondered if you knew anything about the lis driver and
>>>>>> if anyone else is using it and if can be included by default in the
>>>>>> Freebsd port.
>>>>>>
>>>>>> Thanks,
>>>>>> Tom
>>>>>
>>>> _______________________________________________
>>>> LCDproc mailing list
>>>> LCDproc at lists.omnipotent.net
>>>> http://lists.omnipotent.net/mailman/listinfo/lcdproc
>>>
>>> _______________________________________________
>>> LCDproc mailing list
>>> LCDproc at lists.omnipotent.net
>>> http://lists.omnipotent.net/mailman/listinfo/lcdproc
>>>
>>
>> -Daryl
>
>

-Daryl




Archive powered by MHonArc 2.6.18.

Top of page