LCDproc development and user support list

Text archives Help


[Lcdproc] running display in new software environment


Chronological Thread 
  • From: root at c-works.net (Harald Latzko)
  • Subject: [Lcdproc] running display in new software environment
  • Date: Wed, 1 Dec 2010 23:26:59 +0100

Hello,

to answer myself, I debugged some more information. The same panel works with
Linux kernel 2.6.20.2, a working panel under 2.6.20.2 doesn't work with
2.6.35 or 2.6.36.1. It may depend on the used driver (pyramid) which uses the
kernel module ftdi_sio (in kernel 21.6.20, it had version 1.4.3, in 2.6.35
and 2.6.36.1 1.6.0). The main thing is: LCDd works, BUT lcdexec doesn't
really work. Updated information work for (as far as tested) for every
client. LCDexec doesn't show up the correct displayed information. Starting
LCDd in the foreground with debugging information (-f -r 4), it show me that
the keys are responding in realtime:

Driver [pyramid] generated keystroke Escape
screenlist_switch: switched to screen [_menu_screen]
Driver [pyramid] generated keystroke Down
Driver [pyramid] generated keystroke Down
Driver [pyramid] generated keystroke Down

But during pressing the down (or any other) button, the menu of lcdexec is
never shown. Even the LCDd built in menues don't seem to work correctly.
During even more testing, it seems that when handling the menu "blind" (in a
"as I would expect it to do in a working environment"), lcdexec executes the
correct executables (so my assumption is: the underlying menu handling is
working correctly) but the display is never or nearly never actualized (I
sometimes get weird states where the menu is lagging some minutes behind).
Contacting the LCD provider gave me a new cable set which didn't solve the
problem. I tested 0.5.2, 0.5.3 and actual CVS version: no difference.

Anybody out there who's using lcdexec with an actual LCDd with a kernel newer
than 2.6.30?


Am 21.11.2010 um 20:42 schrieb Harald Latzko:

> Hello,
>
> I've got lcdproc 0.5.2 perfectly running in Debian4 (manually compiled
> kernel 2.6.20, driver "pyramid"). LCDd, lcdproc and lcdexec are working
> like a charm, also an own client which just prints out text information on
> the display. The four buttons work as configured.
> Taking this working system, I upgraded the OS with a fresh installation
> Debian 5.0.3, kernel 2.6.26. My first attempts failed:
> - just copying over all files from the old installation: lcdexec never
> shows any sign of existance when pressing the menu button
> - compiling lcdproc 0.5.2 from scratch: pyramid.so doesn't load. Taking the
> 0.5.2 pyramid.so works, but lcdexec doesn't show up.
> - compiling lcdproc 0.5.3 from scratch: same result as 0.5.2 from scratch
> - compiling the daily snapshot of 0.5.3 gives the same result
> LCDd is running with lcdproc correctly, it displays the correct
> information. When running the daemon in foreground and "-r 5" mode I can
> see heavy traffic on the server daemon which is not being displayed on the
> LCD, but it may be of internal reasons I do not understand.
>
> During trying, I got some strange effect that when lcdexec showed the
> correct menu, scrolling through the menu items seemed like "sticked" to the
> first page (but the execution of the menu executables behind the menu
> definition was triggered correctly): the LCD didn't seem to update fast
> enough, or even worse: wasn't updated at all.
>
>
> The required kernel module ftdi_sio is loaded. I set up the local hostname
> in /etc/hosts from 127.0.1.1 to 127.0.0.1 (in addition to "localhost") in
> order to keep networking issues out of place. Since the same LCD module
> works perfectly in a Debian4 environment (and I can reproduce this): what
> are the requirements I might be missing? Does anybody has any hints on
> that? It would be very great to get the panel work again with lcdexec.
>
> Regards,
> Harald
> _______________________________________________
> LCDproc mailing list
> LCDproc at lists.omnipotent.net
> http://lists.omnipotent.net/mailman/listinfo/lcdproc
>





Archive powered by MHonArc 2.6.18.

Top of page