LCDproc development and user support list

Text archives Help


[Lcdproc] SureElec no response, freeze?


Chronological Thread 
  • From: sven at meiers.net (Sven Meier)
  • Subject: [Lcdproc] SureElec no response, freeze?
  • Date: Wed, 24 Nov 2010 19:37:05 +0100

Hi all,

the problem showed up once again :(.

I'm not sure why opening the device sometimes freezes in SureElec.c:

static int
open_port(Driver * drvthis, const char *device)
...
fd = open(device, O_RDWR | O_NOCTTY);

Adding O_NDELAY (as most other drivers do), solves the problem.

Any ideas?

Sven


On Mon, 2010-11-22 at 00:26 +0100, Sven Meier wrote:
> Sorry for the noise, opening the device worked after a fresh login.
>
> BTW is there a specific reason why the SureElec driver is not compiled
> into the official release?
>
> Thanks
>
> Sven
>
> On Sun, 2010-11-21 at 23:25 +0100, Sven Meier wrote:
> > Hi all,
> >
> > I've trying to get my Sure Electronics LCD (DE-LD021) running with
> > lcdproc.
> >
> > Checked out the source, built (?enable-drivers=SureElec,curses) and run
> > with:
> >
> > server/LCDd -fc LCDd.conf
> >
> > ... the following is written to the console:
> >
> > Server running in foreground
> > Listening for queries on 127.0.0.1:13666
> > screenlist_init()
> > driver_load(name="SureElec", filename="server/drivers/SureElec.so")
> > SureElec: using Device /dev/ttyUSB0
> >
> > No output on the LCD, connecting via telnet works but I don't get a
> > response for "hello".
> >
> > Using the "curses" driver works immediately. Could anybody give me a
> > clue what might be wrong here?
> >
> > Thanks
> >
> > Sven
> >
> > _______________________________________________
> > LCDproc mailing list
> > LCDproc at lists.omnipotent.net
> > http://lists.omnipotent.net/mailman/listinfo/lcdproc
>






Archive powered by MHonArc 2.6.18.

Top of page