LCDproc development and user support list

Text archives Help


[Lcdproc] Older vfd lockups


Chronological Thread 
  • From: shane at blackett.co.nz (Shane Blackett)
  • Subject: [Lcdproc] Older vfd lockups
  • Date: Sun, 17 Jan 2010 14:02:05 +1300

Hi,

I have been working with the imon lcd driver for about a year.
Initially I used Ubuntu 9.04 and sometimes it would work for days at a
time but occasionally it would lock hard and you could not unload the
module or restart LCDd.

Upon upgrading to Ubuntu 9.10 it now works for about a second after each
reboot and then locks hard the same.

Intially it wrote some urb errors, which I found a thread on, and
started experimenting with some delays. I didn't have any success
though finding any values that helped me.
However now it doesn't write the same errors to the log, it just locks up.

I installed the special package for enabling development of the lirc
kernel source modules from source and have been tinkering with these. I
believe my kernel source for the lirc_imon driver is up to date
(although I didn't sync up the rest of the lirc kernel module I don't
think it's very out of date). I added some printf debugging for the
write and reads (which you will see in the dmesg log).

I haven't actually tried to use the IR in the device as the IR in the
Hauppauge tuner card that I have has always worked well so I've used
that instead.

[ 18.670927] lirc_dev: IR Remote Control driver registered, major 61
[ 18.672324] lirc_imon: Driver for SoundGraph iMON MultiMedia
IR/Display, v0.6.1
[ 18.672354] lirc_imon: imon_probe: overriding display type to 1 via
modparam
[ 18.672357] lirc_imon: imon_probe: found iMON device (15c2:ffdc, intf0)
[ 18.672361] lirc_imon: imon_probe: found IR endpoint
[ 18.672362] lirc_imon: imon_probe: found display endpoint
[ 18.672364] lirc_imon: imon_probe: ir_onboard_decode: 1
[ 18.672366] lirc_imon: imon_probe: vfd_proto_6p: 1
[ 18.672374] lirc_dev: lirc_register_driver: sample_rate: 0
[ 18.672415] lirc_imon: Registered iMON driver (lirc minor: 0)
[ 18.672468] input: iMON PAD IR Mouse (15c2:ffdc) as
/devices/pci0000:00/0000:00:02.0/usb3/3-4/3-4:1.0/input/input6

[ 18.672518] lirc_imon: imon_probe: Registering iMON display with sysfs
[ 18.676539] lirc_imon: send_packet ffff8801105b48ac 8

I'm happy to try suggestions to try and debug this further but I don't
really have an idea where to look next.
I do still have the 9.04 installation in a partition too, if I can use
this to compare what is going on.

I read the thread for the "imonlcd and 0038 breakage" and didn't really
see anything else I should try although I may have missed some ideas in
there.

Hoping I can help,

Shane.




Archive powered by MHonArc 2.6.18.

Top of page