LCDproc development and user support list

Text archives Help


[Lcdproc] Is anyone making the latest LCDproc from a fresh CVS pull and having compile issues with MacOS?


Chronological Thread 
  • From: ethan.dicks at gmail.com (Ethan Dicks)
  • Subject: [Lcdproc] Is anyone making the latest LCDproc from a fresh CVS pull and having compile issues with MacOS?
  • Date: Sun, 25 Jan 2009 23:05:22 -0500

Hi, All,

I've been working from nightly tarballs for so long that I don't
remember the last time I built from a fresh CVS pull. I tried that
tonight on my Macbook running 10.4 to get ready to submit patches for
the jw002 24x8 LCD and immediately ran into problems in a
non-essential area of the build.

I fetched the code with the instructions from the sourceforge page...

$ cvs -d:pserver:anonymous at lcdproc.cvs.sourceforge.net:/cvsroot/lcdproc
login

$ cvs -z3 -d:pserver:anonymous at lcdproc.cvs.sourceforge.net:/cvsroot/lcdproc
co -P lcdproc

... and ran autogen.sh(per the note in INSTALL), but after a config...

$ ./configure --enable-drivers=curses,MtxOrb,hd44780,picolcd
--enable-libusb --enable-debug --disable-libftdi

... I got this when I tried a 'make'...

$ make
cd . && /bin/sh ./config.status config.h
config.status: creating config.h
config.status: config.h is unchanged
make all-recursive
Making all in shared
make[2]: *** No rule to make target `sockets.c', needed by `sockets.o'. Stop.
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2
$

So... looking for sockets.c, I found it in
lcdproc/contrib/interface-demo2. A 'make' there was even less
successful...

$ make
make: *** No rule to make target `/usr/include/wait.h', needed by
`if_demo.o'. Stop.
$

Now _this_ seems to be an issue that's come up with other software
packages - the code expects to find 'wait.h' but the system provides
'sys/wait.h', and someone commented somewhere that there are dummy
'wait.h' files that just '#include <sys/wait.h>" to get around this
sort of thing. I glanced over the Pyramid demo code but couldn't tell
any details about what platform or distro it was written for.

In contrast, on a recently built openSUSE 11 machine (Linux linux-cjw3
2.6.27.7-9-pae), I was able to cut my install/build commands from this
e-mail and it pulled down, configured, and built with essentially no
squawks (I did notice a complaint about #pragmas in hd44780-uss720.c).

Admittedly, I'm on a Mac, not a Linux box, so I guess I have to ask -
is anyone else doing development on Macs? It's BSD under the hood,
which I know hasn't always been a primary LCDproc development
platform, but I would hope that things work. I won't be upgrading
this machine to 10.5 since I have to return it to my employer soon -
I'll just reimage it rather than try to uproot everything I have going
on it. Obviously, I have other machines to work from, but for the
past 18 months, this has been "my" space for a variety of tasks. I
_do_ have LCDproc running on it, but I've only used nightly tarballs,
not a fresh CVS pull, certainly not since the Pyramid demo was put
into the CVS tree.

So in summary - SUSE, no problems building from CVS fetch; MacOS 10.4
w/gcc version 4.0.1, not even the first file compiles on a system that
_does_ have LCDproc compiled and running from non-CVS-acquired
sources. I am willing to entertain the notion that I'm missing
something component or some step on the Mac, but it's not like I've
_never_ gotten things to work - just this fresh CVS fetch.

Am I alone in this?

-ethan




Archive powered by MHonArc 2.6.18.

Top of page