LCDproc development and user support list

Text archives Help


[Lcdproc] LCDProc CVS + PicoLCD on FreeBSD


Chronological Thread 
  • From: ethan.dicks at gmail.com (Ethan Dicks)
  • Subject: [Lcdproc] LCDProc CVS + PicoLCD on FreeBSD
  • Date: Wed, 14 Jan 2009 19:48:54 -0500

On Wed, Jan 14, 2009 at 6:18 PM, Ernie Cline <ernie.cline at gmail.com> wrote:
> Hello all,
> I recently purchased one of these little guys for eventual use on my
> alix/pfsense based firewall: http://www.mini-box.com/PicoLCD-4X20-Sideshow
> I cannot seem to get it to work! I have tried the mini-box provided version
> of LCDProc, version .5.2 and the latest CVS version, all seem to give the
> same output:
> Server running in foreground
.
.
.
> picolcd: looking for device picoLCD20x2
> picolcd: looking for device picoLCD20x4
> picolcd: no device found
> Driver [picolcd] init failed, return code -1
> Module /usr/local/lib/lcdproc/picolcd.so could not be loaded
.
.
.
> ioctl(4,USB_DEVICEINFO,0xbfbfe960) ERR#6 'Device not configured'
.
.
.
> I'm trying this on FreeBSD 7.1 in emulation (vmware fusion) and FreeBSD 7.0
> directly on hardware, although both report the device just fine in usbdevs:
> addr 1: UHCI root hub, Intel
> addr 2: USB-LCD-4x20, ITUNER INC
> Any help or a point in the right direction would be helpful!

Hi Ernie,

I have both a "Minibox" 20x2 and a "Sideshow" 20x4 display and have
gotten them both working with Linux, but I have no experience with
libusb and FreeBSD. Checking my logs for the Sideshow the last time I
plugged it into a Linux (SUSE) machine, I see...

usb 1-1: new full speed USB device using uhci_hcd and address 3
usb 1-1: configuration #1 chosen from 1 choice
input: ITUNER INC USB-LCD-4x20 as
/devices/pci0000:00/0000:00:1d.0/usb1/1-1/1-1:1.0/input/input7
input,hiddev96,hidraw0: USB HID v1.01 Device [ITUNER INC USB-LCD-4x20]
on usb-0000:00:1d.0-1
usb 1-1: New USB device found, idVendor=04d8, idProduct=c001
usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
usb 1-1: Product: USB-LCD-4x20
usb 1-1: Manufacturer: ITUNER INC
usb 1-1: SerialNumber: Ver.01.11

I am using the complete tarball from picolcd.com of 0.5.2 that
includes the newer picolcd.c and it worked right out of the box on my
system (details below)...

Having fiddled with the older version of the picoLCD code and my
minibox display w/RedHat WS4, I can say that the code for requesting
the system give back HID devices is probably somewhat Linux-specific.
I did try to get things working on my OS 10.4 MacBook Pro, but I ran
into some issues with what version of libusb I had on the system and
calls from picolcd.c not matching up, and I never did resolve it.

So my experience is with two distros of Linux, I had no problem with
libusb on Linux and getting both types of picoLCD working, but I had
no success after a bit of fiddling under BSD (OS X). I _did_ have my
usb4lcd working a year ago on that MacBook, so I know that my usblib
install isn't there entirely defective.

If you are a coder, look into the chain of calls that picolcd.c and
see how it stages its requests to free up a system
HID-driver-encumbered display. I wouldn't be shocked to learn that
there are Linux/BSD differences.

-ethan




Archive powered by MHonArc 2.6.18.

Top of page