LCDproc development and user support list

Text archives Help


[Lcdproc] LCDProc CVS + PicoLCD on FreeBSD


Chronological Thread 
  • From: ernie.cline at gmail.com (Ernie Cline)
  • Subject: [Lcdproc] LCDProc CVS + PicoLCD on FreeBSD
  • Date: Wed, 14 Jan 2009 15:18:55 -0800

Hello all,I recently purchased one of these little guys for eventual use on
my alix/pfsense based firewall:
http://www.mini-box.com/PicoLCD-4X20-Sideshow

I cannot seem to get it to work! I have tried the mini-box provided version
of LCDProc, version .5.2 and the latest CVS version, all seem to give the
same output:

Server running in foreground
Listening for queries on 127.0.0.1:13666
screenlist_init()
driver_load(name="picolcd", filename="/usr/local/lib/lcdproc/picolcd.so")
picolcd: looking for device picoLCD20x2
picolcd: looking for device picoLCD20x4
picolcd: no device found
Driver [picolcd] init failed, return code -1
Module /usr/local/lib/lcdproc/picolcd.so could not be loaded
Could not load driver picolcd
There is no output driver
Critical error while initializing, abort.


if I run a truss against that, the relevant errors seem to be along the
lines of:

ioctl(4,USB_DEVICEINFO,0xbfbfe960) ERR#6 'Device not configured'

I have read a few other errors some involving libusblcd, some saying this is
seen as an HID device when it shouldn't be, but nothing seems to work for
me.

I'm trying this on FreeBSD 7.1 in emulation (vmware fusion) and FreeBSD 7.0
directly on hardware, although both report the device just fine in usbdevs:

addr 1: UHCI root hub, Intel
addr 2: USB-LCD-4x20, ITUNER INC

Any help or a point in the right direction would be helpful!
-------------- next part --------------
An HTML attachment was scrubbed...
URL:
<http://lists.omnipotent.net/pipermail/lcdproc/attachments/20090114/67207fc6/attachment.htm>




Archive powered by MHonArc 2.6.18.

Top of page