LCDproc development and user support list

Text archives Help


[Lcdproc] picolcd build problems


Chronological Thread 
  • From: peterhollas at hotmail.com (Peter Hollas)
  • Subject: [Lcdproc] picolcd build problems
  • Date: Wed, 12 Nov 2008 12:22:04 +0000



Hi,

After a bit of debugging, it appears that there the picolcd driver looks for
LircHost= as a configuration parameter. However, in the /etc/LCDd.conf it is
defined as LircAddress= and so Lirc UDP never gets switched on with the
standard cvs config.

Please could someone submit a correction to cvs.

Thanks, Peter.
From: peterhollas at hotmail.com
To: lcdproc at lists.omnipotent.net
Date: Tue, 11 Nov 2008 18:21:43 +0000
Subject: Re: [Lcdproc] picolcd build problems








Hi,

I have downloaded the latest cvs source and tried again.



I am no longer seeing pkg-config problems when I do the ./configure and
everything compiles and installs without obvious errors.

Everything works fine for the display side of things with the picolcd driver.

Unfortunately I can't seem to get lirc to receive anything on UDP using irw.
I "think" that the picolcd is not sending out UDP but I have no idea how to
test that it. Doing a "nc -p 8765 -u -l" when lircd is disabled also shows
nothing and I have set the UDP options up for the picolcd driver in LCDd.conf
as well as lirc.

Any ideas would be welcome!

Thanks, Peter.


> CC: lcdproc at lists.omnipotent.net
> From: andy at siliconlandmark.com
> To: peterhollas at hotmail.com
> Subject: Re: [Lcdproc] picolcd build problems
> Date: Mon, 10 Nov 2008 10:06:10 -0500
>
> On Nov 10, 2008, at 8:45 AM, Peter Hollas wrote:
>
> > I'm trying to compile the latest cvs version of lcdproc for picolcd
> > 20x2 on Mythbuntu 8.10 and have run into some problems. I had it
> > working flawlessly before on Ubuntu 8.04 but this time I get an
> > error when LCDd tries to load the picolcd driver.
> >
> > root at myth:~/lcdproc# ./configure --enable-libusb --enable-
> > drivers=picolcd
> > ...
> > checking if libusb support has been enabled... yes
> > configure: WARNING: pkg-config not (fully) installed; drivers
> > requiring libusb may not be built
> ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
> This is likely to be the cause of your problems.
>
> > after doing a 'make' and 'make install', everything builds without
> > errors, but when I try to start LCDd I get the following in syslog.
> >
> > Nov 10 12:59:39 myth LCDd: Could not open driver module /usr/lib/
> > lcdproc/picolcd.so: /usr/lib/lcdproc/picolcd.so: undefined symbol:
> > usb_release_interface
> > Nov 10 12:59:39 myth LCDd: Driver [picolcd] binding failed
> > Nov 10 12:59:39 myth LCDd: Could not load driver picolcd
> > Nov 10 12:59:39 myth LCDd: There is no output driver
> > Nov 10 12:59:39 myth LCDd: Critical error while initializing, abort.
> >
> > I'm assuming it's a libusb problem, but as far as I am aware I have
> > the correct packages.
>
> This problem is likely to be caused by the change in CVS with regards
> to pkg-config. Make sure that pkg-config installed correctly prior to
> running configure or hack the Makefile and adjust the linker parameters.
>
> Cheers,
> Andy
>
> /* Andre Guibert de Bruet * 436f 6465 2070 6f65 742e 2042 6974 206a */
> /* Managing Partner * 6f63 6b65 792e 2053 7973 4164 6d69 6e2e */
> /* GSM: +1 734 846 8758 * 2055 4e49 5820 736c 6575 7468 2e00 0000 */
> /* WWW: siliconlandmark.com * C/C++, Java, Perl, PHP, SQL, XHTML, XML */

Click here for FREE customisable desktop wallpapers. Get them Now!
_________________________________________________________________
Win ?1000 John Lewis shopping sprees with BigSnapSearch.com
http://clk.atdmt.com/UKM/go/117442309/direct/01/
-------------- next part --------------
An HTML attachment was scrubbed...
URL:
<http://lists.omnipotent.net/pipermail/lcdproc/attachments/20081112/74c54d94/attachment.htm>




Archive powered by MHonArc 2.6.18.

Top of page