LCDproc development and user support list

Text archives Help


[Lcdproc] MtxOrb VK202-24-USB and weird chars


Chronological Thread 
  • From: nico AT youplala.net (Nicolas Will)
  • Subject: [Lcdproc] MtxOrb VK202-24-USB and weird chars
  • Date: Mon Mar 10 19:16:02 2008

Hi all,

I am using a Matrix Orbital VK202-24-USB VFD on my Home Theatre PC
project, ussing Ubuntu.

http://www.matrixorbital.com/product_info.php?pName=vk20224usb&cName=lcd-character-vfds
http://www.youplala.net/linux/home-theater-pc

Of course, it is using lcdproc!



But...

Things worked very well using 0.5.1.

Then I upgraded the Ubuntu release from 7.04 to 7.10, which brought
0.5.2.

There is some work done on the MtxOrb driver that broke something, as
the display shows 'V' and '|' characters a bit randomly (at least to my
eyes).

I initially trusted the software, and got an RMA from Matrix Orbital
(stellar service, BTW).

But I still had the pb with the brand new unit.

I picked up a 0.5.1 package and installed it. Magic, the display worked
again.

I am currently holding the package to its current version. It works
well, even if it is a bit inelegant.



I then used Google and picked up the following information:

http://lists.omnipotent.net/pipermail/lcdproc/2007-October/011957.html
http://lcdproc.cvs.sourceforge.net/lcdproc/lcdproc/ChangeLog?revision=1.84&view=markup
http://thread.gmane.org/gmane.comp.sysutils.lcdproc/11591

I have opened a bug with Ubuntu:

https://bugs.launchpad.net/ubuntu/+source/lcdproc/+bug/187605

A developer kindly found a patch and applied it, for the next Ubuntu
release. I took the source package and backported it to my current
stable release.

I got the same problem of V and | on the display with this.



The Ubuntu guys are quite hyper these days with the upcoming release.
I can barely read code, but I am not a coder.

I am seeking your help in finding a patch that would apply to the 0.5.2
lcdproc release and fix the MtxOrb, for inclusion into the rapidly
arriving Ubuntu release.



I hope that there will be an understanding person around here ready to
help!

Thanks in advance,

Nico






Archive powered by MHonArc 2.6.18.

Top of page