LCDproc development and user support list

Text archives Help


Fwd: Re: [Lcdproc] Re: VLSYS L.I.S 2005 Driver written


Chronological Thread 
  • From: nic AT postilion.org (Nic Bernstein)
  • Subject: Fwd: Re: [Lcdproc] Re: VLSYS L.I.S 2005 Driver written
  • Date: Wed May 9 12:35:01 2007


Todd Luliak wrote:
> Daryl-
> First of all, thanks for the work you put forth to create the driver. It
> could not have been more timely nor I more happy to see it!
> After patching a clean 0.5.1 source with the patch (which applied clean)
> and running
> ./configure --enable-libusb --enable-drivers=lis I am greeted with:
> > [...snip]
> checking libusb library path... -L/usr/lib -lusb
> checking for main in -lusb... yes
> checking if LDAP support has been enabled... no
> configure: checking for which drivers to compile...
> configure: error: Unknown driver lis
> [/snip...]
> > Poking around now to see where I got lost.
Todd,

After applying the patch run autoconf before running configure.

I don't quite know how to fix the patch for that. I think I just need to
run autoconf and then make the patch so configure.in is used to build
the correct configure script.

Regards,
Daryl
Daryl, I see the following after running autoconf and running configure:
<snip>

Making all in server
make[2]: Entering directory `/home/nic/lcdproc-0.5.1/server'
Making all in drivers
make[3]: Entering directory `/home/nic/lcdproc-0.5.1/server/drivers'
Makefile:262: *** commands commence before first target. Stop.
make[3]: Leaving directory `/home/nic/lcdproc-0.5.1/server/drivers'
make[2]: *** [all-recursive] Error 1

</snip>

Not quite sure what to make about that. I can send the server/drivers/Makefile if that would help. Not sending it to the list as it is 1200 lines long.

Thanks, again, for the effort!
-nic

--
Nic Bernstein
nic AT postilion.org
http://www.fortunespawn.com
All opinions expressed are mine, if you want them it'll cost you.

Todd Luliak wrote:
  
> Daryl-
> First of all, thanks for the work you put forth to create the driver. It
> could not have been more timely nor I more happy to see it!
> After patching a clean 0.5.1 source with the patch (which applied clean)
> and running
> ./configure --enable-libusb --enable-drivers=lis I am greeted with:
> 
> [...snip]
> checking libusb library path... -L/usr/lib -lusb
> checking for main in -lusb... yes
> checking if LDAP support has been enabled... no
> configure: checking for which drivers to compile...
> configure: error: Unknown driver lis
> [/snip...]
> 
> Poking around now to see where I got lost.
Todd,

After applying the patch run autoconf before running configure.

I don't quite know how to fix the patch for that. I think I just need to
run autoconf and then make the patch so configure.in is used to build
the correct configure script.

Regards,
Daryl
  
Daryl, I see the following after running autoconf and running configure:
<snip>
Making all in server
make[2]: Entering directory `/home/nic/lcdproc-0.5.1/server'
Making all in drivers
make[3]: Entering directory `/home/nic/lcdproc-0.5.1/server/drivers'
Makefile:262: *** commands commence before first target.  Stop.
make[3]: Leaving directory `/home/nic/lcdproc-0.5.1/server/drivers'
make[2]: *** [all-recursive] Error 1
</snip>

Not quite sure what to make about that.  I can send the server/drivers/Makefile if that would help.  Not sending it to the list as it is 1200 lines long.

Thanks, again, for the effort!
    -nic
-- 
Nic Bernstein                                  nic AT postilion.org
http://www.fortunespawn.com
All opinions expressed are mine, if you want them it'll cost you.



Archive powered by MHonArc 2.6.18.

Top of page