LCDproc development and user support list

Text archives Help


[Lcdproc] Why aren't the drivers being made?


Chronological Thread 
  • From: peter AT adpm.de (Peter Marschall)
  • Subject: [Lcdproc] Why aren't the drivers being made?
  • Date: Thu May 4 17:51:01 2006

Hi Jason,

I am the current maintainer and I formally converted the MtxOrb driver from
the LCDproc 0.4 API to the 0.5 API.
Not owning the hardware and without the help of a maintainer this was the
only
alternative to completely dropping MtxOrb support in LCDproc 0.5.

On Tuesday, 2. May 2006 22:26, Jason Miller wrote:
> Thanks for the direction. I finally got 0.4 running.

Please not that 0.4.x is out of maintenance for years now.

> Seems didn't need to make a /usr/lib/lcdproc and copy the *.o files over,
> anyway. "Make install" put the put the drivers somewhere. Where, I have
> no idea, but it works...
>
> Also discovered a mistype in /etc/LCDd.conf that I made. I was trying to
> point for LCDd to drive 'ttys0' instead of 'ttyS0'.
>
> I'm still totally and completely confused about what and where the
> "drivers" are, but its running..
>
> ..and (strange), LCDd and lcdproc built with 0.4 are using the backlight
> correctly with the Matrix Orbital 20x4 LCD. (I had used LCDd/lcdproc a
> long, long, time ago with this same LCD and it worked great. Thats what
> led to trying out something other than 0.5. Why the backlight works with
> 0.4 and not 0.5, I have not the slightest clue! )

I am glad to hear that my formal conversion of the driver to the new API
only broke the backlight support. (I was not able to test it at all ;-)))

May I ask you to support LCDproc and do a bit of R&D on the MtxOrb
driver of LCDproc 0.5.

Yours
Peter


--
Peter Marschall
peter AT adpm.de




Archive powered by MHonArc 2.6.18.

Top of page