LCDproc development and user support list

Text archives Help


[Lcdproc] install directories in lcdproc-CVS-stable-0-5-x-20060427


Chronological Thread 
  • From: peter AT adpm.de (Peter Marschall)
  • Subject: [Lcdproc] install directories in lcdproc-CVS-stable-0-5-x-20060427
  • Date: Sat Apr 29 22:05:12 2006

Hi,

On Saturday, 29. April 2006 02:20, Stewart W. Putnam wrote:
> So maybe I'm confused ... maybe I did something ...
>
> I downloaded the tarball lcdproc-CVS-stable-0-5-x.tar.bz2 and did my usual
>
> ./configure --enable-drivers=3Dall --prefix=3D/usr
>
> for starters. That's always worked on my Debian box.
>
> Tail end of the make says:
> > echo " /usr/bin/install -c -m 644 $d$p /usr/etc/$f"; \
> > /usr/bin/install -c -m 644 $d$p /usr/etc/$f; \
>
> and
>
> > .../lcdproc-CVS-stable-0-5-x-20060427# ./server/LCDd -r3
> > LCDd version CVS-stable-0-5-x-20060427 starting
> > Using Configuration File: /usr/etc/LCDd.conf
> > Could not read config file: /usr/etc/LCDd.conf
>
> I tried experimenting with some of the configure options I hadn't tried
> before; --exec-prefix=3D, --sysconfdir=3D/ ... and none of them seem to be
> getting it right for me, cant get rid of the "/usr/etc/"

=2E/configure --enable-drivers=3Dall --prefix=3D/usr --sysconfdir=3D/etc
on a _freshly_ extracted tar ball should do the trick.
It defintively does on my Debian system.

=46rom time to time I experience similar problems (i.e. directories given=20
as ./configure options not taking effects) when I run ./configure a
2nd time with different options than in the first run.

Doing it on a freshly extracted source or a source cleaned with=20
'make distclean' always helped.

Hope it helps
Peter

=2D-=20
Peter Marschall
peter AT adpm.de




Archive powered by MHonArc 2.6.18.

Top of page