LCDproc development and user support list

Text archives Help


[Lcdproc] HD44780-winamp gets overflooded with Hearts after upgrading to CVS


Chronological Thread 
  • From: dura-zell AT dynamik.sytes.net (Sven Mertens)
  • Subject: [Lcdproc] HD44780-winamp gets overflooded with Hearts after upgrading to CVS
  • Date: Thu Mar 10 21:44:01 2005

Joris Robijn schrieb:
> On 10 Mar 2005 at 21:18, Sven Mertens wrote:
>
>
>>Since I have to use 0.4.5 to initialize my display (it does really
>>nothing if 0.5 is started without starting and killing 0.4.5 in
>>advance), is it possible that there's a problem with the
>>display-initialization?
>
>
> Probably. Be our guest in finding out where the problem is.
>
> You have to understand it is not a strait path to determine the complete
> initialisation sequence. It has to work for all possible options and all
> displays. Maybe a delay somewhere in the init needs to be increased. So
> if we would exactly know what modification makes it work for you, that
> change can probably be integrated into the source.
>
> Joris
> --
> Joris Robijn
> <joris AT robijn.net>
> Mobile: +31 6 288 41 964
>
> // To understand recursion, we must first understand recursion
>
> _______________________________________________
> LCDproc mailing list
> LCDproc AT lists.omnipotent.net
> http://lists.omnipotent.net/mailman/listinfo/lcdproc
>
>

Hi Joris,
I hope you didn't misunderstood my last post. I never wanted to blame
anybody for what is happening between lcdproc, my parallelport and the
display. If you understood the post like this, again, take my excuses
and I will blame my bad english for that. ;) If not, nevertheless I will
blame my bad english for misunderstanding you.
Since there are people out there, wich seems to have working hd44780 /
KS0066 displays (In fact it seems that I'm the only one who has this
problem), I think this is an initializiation problem with my specific
combination of hardware and software and not the fault of lcdproc all
alone. Since I'm not able to modify my hardware, I have to work with the
software.

And thanks for your invitation, I'll accept it gladly. :) Maybe I can
help to find a problem. If there's any, I would appreciate to help
finding it.

Ah, and I believe I have understood that the initialization is a complex
process, like the communication with the Device in general is. When I
became surer that the solution to my problem is somewhere in the code,
I've read the files (many times) and tried to understand them. I also
tried to understand the protocol between the display and the lpt but I'm
far away from understanding it with my limited experience in programming
with C.

So, here's wich configuration / modifiaction is getting me to wich results:

Version 0.4.5
-------------
Normal compile, as downloaded from the website.
Works fine for aproximatly two hours, then freezes the whole machine.

Didn't try to modify the code here. Got recommandation to upgrade to the
CVS version wich brought me here. Tried with two different computers,
both locked up after two hours.


Version 0.5 CVS
---------------
Normal compile, as downloaded from the website.
Doesn't show up on the display, no errors on the console / log

Modified compile with suggestions from Andrés Trapanotto:
Compiles, runs, but did not show anything on the display


Version 0.4.5 + 0.5 CVS
-----------------------
This is what I'm currently working with.
After a complete reset of the display (disconnect from power and data
lines) there's nbothing but the wellknown two lines. Now I start the
daemon of the 0.4.5 version. When it has started up completly I kill it.
Now I can start the daemon of 0.5-CVS. It shows up on the display as it
should but with the hearts I mentioned before.

So, to answer your question, currently no configuration / modification
is working for me. Btw, my Portsettings and ConnectionType are correct.


Greetings,
Sven Mertens




Archive powered by MHonArc 2.6.18.

Top of page