LCDproc development and user support list

Text archives Help


[Lcdproc] Problems with Matrix Orbital LK202-24-USB


Chronological Thread 
  • From: darren AT boncey.org (Darren Greaves)
  • Subject: [Lcdproc] Problems with Matrix Orbital LK202-24-USB
  • Date: Thu Oct 28 12:19:02 2004

Hi, I bought a Matrix Orbital LK202-24-USB and have not been able to get
it working under Linux using LCDproc.
The display works fine in Windows however so I don't think it's a
hardware problem.

Background info:
Distro - Slackware 9
Kernel - 2.4.27
LCDproc - 0.4.4
Device - Matrix Orbital LK202-24-USB

Description of problem:
When I boot the machine I get the standard Matrix Orbital logo on it.
When I start LCDd I get the LCDproc screen on there which says "Clients
0, Screens 0".
I run lcdproc C (same problem no matter what options I specify) but the
screen does not change. I have to to send a kill -9 as root to stop
LCDd after that (pressing CTRL-C says "Server shutting down on SIGINT"
then hangs).
Sometimes when I run LCDd the screen corrupts a few characters in the
top left corner - that's the most I've ever got the display to do.

Running LCDd with maximum verbosity shows that it stops its
drivers_getkey loop after 2 or 3 iterations, it then hangs (as far as I
can tell).

My config is as follows.
[server] (some options removed for brevity).
Driver=MtxOrb
Bind=127.0.0.1
Port=13666
ReportLevel=5
User=root (I did try as nobody first).

[MtxOrb] (I included all from this section though).
USB=yes
size=20x2
enablebacklight=yes
contrast=140
speed=19200
type=lcd
device=/dev/ttyUSB0
keypad_test_mode=no

I can attach the entire config file if required.

If more info is required, please feel free to ask.


Thanks in advance for any help.




Archive powered by MHonArc 2.6.18.

Top of page