LCDproc development and user support list

Text archives Help


[Lcdproc] HD44780 And Freebsd UPDATE


Chronological Thread 
  • From: fredrik.nordanmyr AT infotech-kd.se (Fredrik Nordanmyr)
  • Subject: [Lcdproc] HD44780 And Freebsd UPDATE
  • Date: Sat Oct 5 16:06:01 2002

The vspan=2,2 fixed it.
But the timing is still so slow, maybe for i'm using an old display (i don't
know).
And the client screens seems to be a little off on freebsd (122% idle ??)
i don't know diddly about programing, but i cant test hd44780 40x4 and
mtxorb 20x4 (w. keys) on freebsd.

/Fredrik

-----Original Message-----
From:
lcdproc-admin AT lists.omnipotent.net
[mailto:lcdproc-admin AT lists.omnipotent.net]On
Behalf Of Joris Robijn
Sent: den 5 oktober 2002 13:36
To:
fredrik.nordanmyr AT infotech-kd.se
Cc:
lcdproc AT lists.omnipotent.net
Subject: RE: [Lcdproc] HD44780 And Freebsd UPDATE


On 4 Oct 2002 at 19:08, Fredrik Nordanmyr wrote:

> Ok. i fiddled around some in the config file, and found vspan=1,2 , that
> didn't work, exept that line 1 is ok line 2 is empty line is line 2 and
> line 4 is on line 1 and 3 (hope someone understands :-) ). I also changed
> the "DelayBus" setting to "false" and it got alot faster but not as fast
> as my mtxorb display. Hope this info helps.

I think you need 2,2 . Is it wrong in the docs ? Please let me know so I
can update it. Again, I see it's time to get my 40x4 running.

The timing might be improved by selecting another timing mechanism in
timing.h. There are/were some issues with timing, it's been solved for
most situations (in the past it was much worse ;) FreeBSD has some
different high-res timing functions than Linux.

Joris

>
> -----Original Message-----
> From:
> lcdproc-admin AT lists.omnipotent.net
> [mailto:lcdproc-admin AT lists.omnipotent.net]On
> Behalf Of Fredrik
> Nordanmyr
> Sent: den 4 oktober 2002 18:56
> To:
> lcdproc AT lists.omnipotent.net
> Subject: RE: [Lcdproc] HD44780 And Freebsd
>
>
> Hi all and thanks for all your help :-))
>
> I finaly got it running.
> BUT..... it's so slow when rinnging the HD44780 driver, curses and mtxorb
> works just fine. The lines are mixed up also. When i'm running 40x4 it get
> mixed up , and when i run 20x4 it splits the display in 2 , and using the
> right of the display for the 2 bottom lines and no text in the lower two
> lines. And i thing there is a bug in [T]ime or i have the best computer in
> the world, it shows that it is 111% idle ;-) I'm just testing here as the
> newbe i am, and hoping that someone will have a sollution that i can test.
>
> //Fredrik (Just loves lcdproc, pure-ftpd, freebsd, macosx)
>
>


_______________________________________________
LCDproc mailing list
LCDproc AT lists.omnipotent.net
http://lists.omnipotent.net/mailman/listinfo/lcdproc








Archive powered by MHonArc 2.6.18.

Top of page