LCDproc development and user support list

Text archives Help


[Lcdproc] hd44780 weird display/driver problem


Chronological Thread 
  • From: robijn AT natlab.research.philips.com (Joris Robijn)
  • Subject: [Lcdproc] hd44780 weird display/driver problem
  • Date: Thu Oct 3 07:43:01 2002

> So.. here are the docs I'm reading.
> http://mywebpages.comcast.net/biglittlekid/systems/LCD_DMC_manual.pdf
> Secion 1.7.4 (page 15) says there are exactly 80 bytes. This works
> with my theory about the wrapping. Section 1.7.6.3 (page 17) says line
> two starts at 0x40, but I think it's just wrong given the symptoms.
> Now the important part is page 32, where it describes the
> initialization steps. Note the extra stuff that lcdproc doesn't do.
> I have all this (but no uPause after the third FUNCSET|8bit).

You're completely right. It HAS 80 bytes and the source has a
bug there. I'll fix that.

I still gt surprised by how some bugs can remain in the source
for these amounts of time. I need to connect my 40x4 too...

> Right now everything seems good except I dont get the PC-poweron black
> line which I can deal with, maybe this unit just doesn't do that...
> and I simply dont get line 2. What can I do about the
> initialization to try to get the unit to see that 2lines bit? Any
> suggestions?

try delays before or after.

Joris
--
Joris Robijn
<joris AT robijn.net>
Phone: +31 6 288 41 964

// To understand recursion, we must first understand recursion






Archive powered by MHonArc 2.6.18.

Top of page