LCDproc development and user support list

Text archives Help


[Lcdproc] hd44780 weird display/driver problem


Chronological Thread 
  • From: robijn AT natlab.research.philips.com (Joris Robijn)
  • Subject: [Lcdproc] hd44780 weird display/driver problem
  • Date: Wed Oct 2 08:47:01 2002

> > line, and some of the second line characters intertwined on line 1.=A0
> > Nothing ever shows up on line 2. =A0 Note that as soon as I close the
> > winamp mode, if I run it again it displays nothing, and I have to
> > start over in 8bit mode.=A0=A0=A0 Uuuggh!=A0=A0 Can anyone help me?=A0=
Is it
> > possible that any hd44780 uses different protocols or wiring?
>
> Some time ago, I had the same problems with my display. It had to do
> with timing problems (a bug) in the winamp driver. Some
> multiplications with the multDelay variable had been missing in the
> initialization section... I posted my changes to the list some time
> ago...
>
> Bye, Oli

Yes you're right ...

Joris

--------

On 10 Jul 2002 at 20:48, Marc-Oliver Straub wrote:

> Hi,
>
> Sometimes my 40x4 display wouldn't come up at boot partially (first 2 li=
nes,
> second two lines, or none). Since I changed the init function by adding =
the
> delayMult factor, it seems to work without problems. Here are the change=
d
> lines:
>
> 77: extern int delayMult;
> 112: hd44780_functions->uPause (4100 * delayMult);
> 114: hd44780_functions->uPause (100 * delayMult);
> 116: hd44780_functions->uPause (40 * delayMult);
>
> Can someone please add these changes to the cvs version?

I guess that's a job for me...

Thanks for your report.

Joris

>
> _______________________________________________
> LCDproc mailing list
> LCDproc AT lists.omnipotent.net
> http://lists.omnipotent.net/mailman/listinfo/lcdproc

--
Joris Robijn
<joris AT robijn.net>
Phone: +31 6 288 41 964

// To understand recursion, we must first understand recursion






Archive powered by MHonArc 2.6.18.

Top of page