LCDproc development and user support list

Text archives Help


[Lcdproc] hd44780 weird display/driver problem


Chronological Thread 
  • From: nchidsey AT bw.edu (Nick Chidsey)
  • Subject: [Lcdproc] hd44780 weird display/driver problem
  • Date: Wed Oct 2 01:22:01 2002

> > I have a 40x2 HD44780 in the "winamp" wiring scheme. Two weird things,
> > probably related:
> > 1) I HAVE to run LCDd once in "8bit" mode, THEN run in "winamp" mode
> > for anything to be
> > displayed. Just running winamp makes a blank screen.During 8bit, there
> > is no display, but as soon as I close LCDd, the ending message shows
> > up. (But it is garbled as described below).
> > 2)Itdisplays the first
> > line, and some of the second line characters intertwined on line 1.
> > Nothing ever shows up on line 2.
>
> Now that's weird. Both wiring methods use the same logical code.
> Only at the level of 'which bit is which wire' they are
> different (plus the 8bit can do something with some old external
> program but that does not make any difference). Are you sure
> you've wired it correctly ?

I've now switched to the 8bit mode, (lcdtime) by simply swapping the Enable
and RegSelect wires. The exact same thing happens as above, only swap the
mode names. I know I have wired it correctly, however I bought the display
from someone on ebay and I do not have the pin names, only numbers 1-14.
(Note: 2 rows of 7 pins, and they alternate: 1,3,5,7,9,11,13 and
2,4,6,8,10,12,14.


>
> Can you tell us what version of LCDproc you are using and where
> you got it from ?
lcdproc-0.4.3 I'm afraid I can't remember where i downloaded it from

>
> > Note that as soon as I close the winamp mode, if I run it again it
> > displays nothing, and I have to start over in 8bit mode. Uuuggh! Can
> > anyone help me? Is it possible that any hd44780 uses different
> > protocols or wiring?
>
> Did you set the display size correctly ? Have you tried the
> speed tweaks ? See docs at http://lcdproc.sourceforge.net/docs/

Yep. (if by speed tweaks you mean the delay multiplier, I tried 2 and 4 to
no effect).
Also:
1) I've removed the potentiometer and just grounded the contrast pin:
exactly the same.
2) I've grounded the R/W pin also instead of connecting it to the LPT: also
exactly the same.

Here's something new. I just yanked the parallel connector from my pc
(leaving only the +5V/GND connected) and I finally got that black bar on
line 1. I do not get that when I power on the PC, only by doing this.
But after putting it back in and running LCDd, the same weirdness happens.
Question though: Does the BIOS setting for the LPT port matter? Or do I
have to disable it in linux similar to "setserial /dev/ttyS0 uart none"? Or
what pins on my LCD unit could be different so that it *sorta* works but not
quite? Seems that would be awefully hard to get so close if even only two
of the pins were swapped.... (I hate to even ask, but what are the chances
that this is because the unit I bought on ebay is faulty?)

My bios setting is "Bi-directional". Linux bootup reports: "PC-style
[PCSPP,TRISTATE]"


Thank you very much for helping.
-nick






Archive powered by MHonArc 2.6.18.

Top of page