LCDproc development and user support list

Text archives Help


[Lcdproc] NetBSD & LCDproc saga continues


Chronological Thread 
  • From: gfk AT logidac.com (Guillaume Filion)
  • Subject: [Lcdproc] NetBSD & LCDproc saga continues
  • Date: Sat Dec 1 01:07:01 2001

Hi all,

I've finished my fix for the missing ACS_S3, ACS_S7, wcolor_set() and
redrawwin() with the curses driver. It compiles on Debian 2.2, RedHat
6.2, FreeBSD 4.3, SunOS 5.5.1 and SunOS 5.8. It runs on RedHat 6.2.

Collin, could you try it on NetBSD (you can use tomorrow's build or
directly from CVS)?

Here are the files that changed:
-----
Checking in acconfig.h;
/cvsroot/lcdproc/lcdproc/acconfig.h,v <-- acconfig.h
new revision: 1.20; previous revision: 1.19
done
Checking in acinclude.m4;
/cvsroot/lcdproc/lcdproc/acinclude.m4,v <-- acinclude.m4
new revision: 1.21; previous revision: 1.20
done
Checking in server/drivers/curses_drv.c;
/cvsroot/lcdproc/lcdproc/server/drivers/curses_drv.c,v <-- curses_drv.c
new revision: 1.31; previous revision: 1.30
done
-----

As for the problems with the lcdproc client, I have no idea on how to
solve this... Who made this client? And more important, who can solve
this?

Maibe it's because you're running this on an Alpha, because this
driver tries to access memory and processus information. Also, does
the other drivers work?

Best,
GFK's

At 10:06 +1100 30/11/01, Collin Baillie wrote:
Guillaume,

I ran lcdproc in all of its different modes and here are the results:

NetBSD 1.5 (GENERIC) #10: Wed Nov 22 03:00:56 PST 2000

Welcome to NetBSD!

$ cd tmp/lcdproc-CVS-20011127/clients
$ ls
Makefile Makefile.am Makefile.in examples headlines lcdproc
$ cd lcdproc
$ ./lcdproc C
get_load:: Bad file descriptor
$ ./lcdproc X
get_load:: Bad file descriptor
$ ./lcdproc U
get_uptime:: Bad file descriptor
$ ./lcdproc T
get_uptime:: Bad file descriptor
$ ./lcdproc G
get_load:: Bad file descriptor
$ ./lcdproc M
Can't open /proc/meminfo: No such file or directory
$ ./lcdproc B <---------------------------------- This one worked=
!!
^C$
$ ./lcdproc S
Can't open /proc/meminfo: No such file or directory
$ ./lcdproc O <---------------------------------- This one worked=
!!
^C$ ./lcdproc K <---------------------------------- This
one worked!!
^C$ ./lcdproc P
get_load: Bad file descriptor
$ ./lcdproc A
^C$ ./lcdproc D
Segmentation fault - core dumped
$ gdb --core=3Dlcdproc.core
GNU gdb 4.17
Copyright 1998 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions=
=2E
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB. Type "show warranty" for details.
This GDB was configured as "alpha--netbsd".
Core was generated by `lcdproc'.
Program terminated with signal 11, Segmentation fault.

warning: Hit heuristic-fence-post without finding

warning: enclosing function for address 0x1603bdd00
This warning occurs if you are debugging a function without any symbols
(for example, in a stripped executable). In that case, you may wish to
increase the size of the search with the `set heuristic-fence-post' command.

Otherwise, you told GDB there was a function where there isn't one, or
(more likely) you have encountered a bug in GDB.
#0 0x1603bdd00 in ?? ()
(gdb) backtrace
#0 0x1603bdd00 in ?? ()
warning: Hit heuristic-fence-post without finding
warning: enclosing function for address 0x1ffffa128
(gdb) quit
$


Keep in mind, I *am* running this on an alpha. I don't know how that
would affect much of this. Probably doesn't. But I just thought I'd
remind you :)

Cheers,

Collin Baillie
--
Guillaume Filion
Logidac Tech., Beaumont, Qu=E9bec, Canada - http://logidac.com/
PGP Key and more: http://guillaume.filion.org/ (this will redirect)
PGP Fingerprint: 14A6 720A F7BA 6C87 2331 33FD 467E 9198 3DED D5CA




Archive powered by MHonArc 2.6.18.

Top of page