LCDproc development and user support list

Text archives Help


[Lcdproc] strange characters


Chronological Thread 
  • From: bubeck AT informatik.uni-tuebingen.de (Dr. Tilmann Bubeck)
  • Subject: [Lcdproc] strange characters
  • Date: Wed Oct 31 14:10:02 2001

I'm using lcdproc together with a hd44780 connected with 4 bit. The
hd44780 has an external power supply and works even if the computer is
switched off. I use this to display some information of the last run
of my computer.

Whenever I switch my computer off, the display remains in the state
which it was, when the computer was running. However, when I switch on
the light in the room (!) I get random chars appearing on the
display. I think there must be a raising edge on "EN" even if the
computer is off? It must have something to do with the light of the
room??

I connected "EN" as follows:

power supply printer port LCD

D0 (2) D4 (11)
D1 (3) D5 (12)
D2 (4) D6 (13)
D3 (5) D7 (14)
D4 (6) RS (4)
D5 (7) RW (5)
D6 (8) ------ EN (6)
|
| | R=
|_| 100 K
|
Vcc ------------------------- Vcc (2)
GND ---------- GND(25) ----- GND (1)

The resistor "R" should be a pull-up resistor to ensure, that "EN" is
always up, especially when the computer is switched off. However, this
does not seem to always work...

Could anyone please help?

Thanks,
Till


=====
+-------+-------------------------------------------------------------+
| | dr. tilmann bubeck reinform medien- und |
| rein | informationstechnologie AG |
| form | cell.: +49 (172) 8 84 29 72 koenigstrasse 80 |
| AG | fax : +49 (711) 7 22 77 34 70173 stuttgart / germany |
| | email:
t.bubeck AT reinform-ag.com
http://www.reinform-ag.com |
+-------+----------------------------------------------(in gruendung)-+

__________________________________________________
Do You Yahoo!?
Make a great connection at Yahoo! Personals.
http://personals.yahoo.com




Archive powered by MHonArc 2.6.18.

Top of page