LCDproc development and user support list

Text archives Help


[lcdproc] anyone know what this i/o error is?


Chronological Thread 
  • From: willfe AT yahoo.com (William Ferrell)
  • Subject: [lcdproc] anyone know what this i/o error is?
  • Date: Thu, 23 Mar 2000 09:31:25 -0800 (PST)

--- Aaron Solochek
<aarons AT andrew.cmu.edu>
wrote:
> I've been using lcdproc for over a year now, but when I recently
> reinstalled my system (was debian potato, now is debian potato) I can't
> get any version of lcdproc to work. I get
>
> leko:/usr/local/bin#./LCDd -t 20x4 -d MtxOrb -b on
> MtxOrb_init: failed (Input/output error)
> Error loading driver MtxOrb. Continuing anyway...
>
> I have tried both serial ports, and neither works. And I know its 1
> anyways, since my UPS is 0. This is really frustrating, since I came to
> depend on the lcd for lots of info.

I'm guessing this is a permissions problem. You mentioned a reinstall, so
check to make sure that /dev/ttyS0 or whatever is set right. If you're
running LCDd as root, it should be fine anyway, but if you are running it
as a normal user, make sure that user's got read/write access to the port.

If that's not the problem, make sure setserial isn't screwing up your port
configuration.

Let me know if this doesn't work.

=====
Friends help you move, but real friends help you move bodies.

__________________________________________________
Do You Yahoo!?
Talk to your friends online with Yahoo! Messenger.
http://im.yahoo.com


-----------------------------------------------------------
To unsubscribe from this list send a blank message to
lcdproc-unsubscribe AT lists.omnipotent.net




Archive powered by MHonArc 2.6.18.

Top of page