LCDproc development and user support list

Text archives Help


[lcdproc] Automake - how?


Chronological Thread 
  • From: andrew AT mandel.demon.co.uk (Andrew Moyns)
  • Subject: [lcdproc] Automake - how?
  • Date: Mon, 27 Dec 1999 23:14:26 -0000

Hi all,

I've been playing with LCDProc 0.4pre9 for a few weeks now (it's very good)
and I've been lurking and learning on this here list. I have tried several
HD44780 based displays, including 16x2, 16x4 and now a 40x4. I've used them
quite a bit in microcontroller circuits.

All was working well, I made some of my own mods to the driver (speed-ups, a
cache, read/write mode, 8 bit etc) just to see what was going on, but in an
attempt to stay up to date, I retrieved the latest CVS packaged version. I
installed automake (v1.4) & autoconf (v2.13). I'm using WinCVS 1.1b7. I'm
on Linux kernel 2.2.13, if it matters.

I'm not really familar with the workings of automake, but in the absence of
insructions I run autogen.sh [right, yes?]
Then :-
julia:~/lcdproccvs/lcdproc #
./configure --prefix=/usr/local --enable-drivers=all
creating cache ./config.cache
: command not found
checking for a BSD compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking whether make sets ${MAKE}... yes
checking for working aclocal... found
checking for working autoconf... found
checking for working automake... found
checking for working autoheader... found
checking for working makeinfo... found
: command not found
: command not found
: command not found
checking host system type... i586-pc-linux-gnu
: command not found
'/configure: line 825: syntax error near unexpected token `in
'/configure: line 825: `case "$host" in

Fiddled that error, configure now completes. Is this a shell problem ?
(bash v2.02.1(1)) What's with all the "command not found", what commands?

Then, I make and it finishes with :-
make[3]: Entering directory `/root/lcdproccvs/lcdproc/clients/lcdproc'
[some lines removed]
gcc -DHAVE_CONFIG_H -I. -I. -I../.. -Wall -Wp,-lang-c-c++-comments -O6 -
Wno-unused -c disk.c
disk.c:88: #error "statfs for this system noy yet supported"
make[3]: *** [disk.o] Error 1

The file disk.c is choosing which statfs function call to use, and finds
none! As the file is the same as from lcdproc-0.4-pre9.tar.gz which
compiles fine, I must be doing something wrong, or the automake stuff is
broken...

I'd appreciate any help which can get me compiling again. Even building
glibc2 wasn't this painful... TIA

Regards,
Andrew






-----------------------------------------------------------
To unsubscribe from this list send a blank message to
lcdproc-unsubscribe AT lists.omnipotent.net




Archive powered by MHonArc 2.6.18.

Top of page