LCDproc development and user support list

Text archives Help


[lcdproc] [Fwd: [lcdproc] Sort of on topic: LCDd & Add-in Serial Cards]


Chronological Thread 
  • From: n0ety AT home.com (Dean Maluski)
  • Subject: [lcdproc] [Fwd: [lcdproc] Sort of on topic: LCDd & Add-in Serial Cards]
  • Date: Tue, 22 Jun 1999 06:35:14 -0400

Yes, I have always tried to maximize my options with serial ports.
I'm a ham and use 1 port for Packet Radio, 1 for Modem (Before cable
modem), 1 for mouse. Serial Howto says there are work arounds to get
the ttyS* to see other IRQ's but their methods never worked for me. The
easiest fix I found was to go to /usr/src/linux/drivers/char directory
and edit serial.c.
Lines that I change look like this
struct async_struct rs_table[] = {
/* UART CLK PORT IRQ FLAGS */
{ 0, BASE_BAUD, 0x3f8, 4, STD_COM_FLAGS }, /*ttyS0 */

I'm sorry I don't have time to edit or type the whole darn thing in, but
there are 4 lines just like the one above. Change the IRQ as needed and
rebuild the kernel. This is the first instance in the file, reason I
say that is the file is very long to cover many add on boards. If I just
edit the IRQ's in the first instance after the REM statements it pretty
much takes care of it. Hope this helps and sorry I don't have time this
morning for a better detailed expression. Gotta get to work.
Good Luck,
Dean Maluski

--
LINUX RULES
de
n0ety


--- Begin Message ---
  • From: MishtaEcks <insane AT netset.com>
  • To: lcdproc AT lists.omnipotent.net
  • Subject: [lcdproc] Sort of on topic: LCDd & Add-in Serial Cards
  • Date: Tue, 22 Jun 1999 01:27:10 -0400 (EDT)
  • "x-no-archive: yes"
  • Mailing-list: contact lcdproc-help AT lists.omnipotent.net; run by ezmlm
I realize this isn't wholly on topic, but I figured that among all of the
Matrix Orbital users out there, someone else must have run into the same
problem, so I hope no one takes offense that I post this here.

I only have 2 serial ports on-board, but 3 neccesary devices, a modem,
mouse, and my matrix orbital of course. I purchased a MultiTech
Intelligent Serial Interface Model ISI551 ISA 1 port serial card. I had a
heck of a time getting it installed, until I figured out that I needed
shared interrupts turned on in the linux kernel (2.2 series).

All seemed to go well (I thought I saw the mouse and the LCD both working
at the same time), until I just noticed about 10 minutes ago that my
LCD wasn't updating. I killed LCDd and my clients off, and restarted them,
but no updating is occuring.

Here's my layout:

ttyS0 [0x3f8 on irq 4] : Matrix Orbital
ttyS1 [0x2f8 on irq 3] : Modem
ttyS2 [0x3e8 on irq 4] : Mouse

I noticed when I launch LCDd that it doesn't seem to fork off correctly,
as I have to control-c out of it, and even then it doesn't refresh the
display. Launching clients doesn't seem to have any effect on the actual
display.

I can jumper my card to irq 2, 3, 4, 5, 7, 10, 11, 12, or 15, and use just
about any IO space I want via 8 dip switches.

Can anyone shed any light on my problem? Personal e-mail replies are fine
if this traffic is annoying to list members.

-+-+-
The perfection of innocence, indeed, is madness. - Arthur Miller
PGP Key Available - Mail Me w/Subject 'send pgpkey'
Key Fingerprint Follows E5AE 6F83 9020 6C9A 3359 5437 ADCE 1BD5




-----------------------------------------------------------
To unsubscribe from this list send a blank message to
lcdproc-unsubscribe AT lists.omnipotent.net



--- End Message ---

-----------------------------------------------------------
To unsubscribe from this list send a blank message to
lcdproc-unsubscribe AT lists.omnipotent.net

  • [lcdproc] [Fwd: [lcdproc] Sort of on topic: LCDd & Add-in Serial Cards], Dean Maluski, 06/22/1999

Archive powered by MHonArc 2.6.18.

Top of page